eBanking Browsers

Browsers to Access eBanking at RBT

For maximum security and optimal usability, RBT encourages you to use the latest supported Operating Systems and browsers when accessing online banking. Please contact us with questions about mobile browsers.

Effective June 18, 2020: Users accessing RBT Mobile must be on version 4.6.2 or newer for phones or version 4.6 or newer for tablets. Updating your technology can keep you safe from cybercrime. Read more here.

Effective June 11, 2020, the following Operating Systems and Browsers are supported for Consumer eBanking (CeB):

Operating System Apple Safari
Microsoft Internet Explorer Edge Mozilla Firefox Google Chrome
Windows 8.1 n/a 11.0 n/a 76.0 83.0
Windows 10 n/a n/a 83.0 76.0 83.0
Mac OS X 10.15.5 (Catalina) 13.1.1 n/a n/a 77.0 83.0
Mac OS X 10.14 (Mojave) 13.0.1 n/a n/a 76.0 83.0

Note: Cookies and JavaScript must be enabled.

Effective November 10, 2019, the following Operating Systems and Browsers are supported for Business eBanking (BeB):

Operating System Apple Safari Microsoft Internet Explorer Microsoft Edge Mozilla Firefox Google Chrome
Windows 7, 64 bit n/a 11 n/a 68 or latest 75 or latest
Windows 8.1, 64 bit n/a 11 n/a 68 or latest 75 or latest
Windows 10, 32 bit n/a 11 44 or latest 68 or latest 75 or latest
Windows 10, 64 bit n/a 11 44 or latest 68 or latest 75 or latest
Mac OS X 10.12 (Sierra) 12 n/a n/a n/a n/a
Mac OS X 10.13 (High Sierra) 12 n/a n/a n/a n/a

As of March 22, 2017,  the following Operating Systems and Browsers are supported for Commercial Capture Xpress (CCX):

Operating System Apple Safari Microsoft Internet Explorer Microsoft Edge Mozilla Firefox Google Chrome
Windows 7, 32 or 64 bit n/a 11 or higher for use with Java or WebScan WebScan only 11.0 or higher for use with Java or WebScan 20 or higher with WebScan only
Windows 8.1, 32 or 64 bit n/a 11 or higher for use with Java or WebScan WebScan only 11.0 or higher for use with Java or WebScan 20 or higher with WebScan only
Windows 10, 32 or 64 bit n/a 11 or higher for use with Java or WebScan WebScan only 11.0 or higher for use with Java or WebScan 20 or higher with WebScan only
Mac OS X 10.7.3 or higher 5.0 or higher with Java only n/a n/a n/a n/a
Scroll to Top